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Chapitre 1 
Notions de télédétection 
 

 
 

Origine 
 
Le terme de “Télédétection” (Remote sensing) a été utilisé pour la première fois, en1960 par 
Mme Evelyn L. Pruitt du bureau de la recherche navale des Etats-Unis, pour regrouper la 
photographie aérienne, l'obtention d'images par satellite, ainsi que d'autres formes de collecte 
de données à distance. 
 
La technique de la télédétection remonte au XIXème siècle. La mise au point de la photographie 
en 1839 par les français J. Daguerre (1787-1851) et Joseph Nicephore Niepce (1827) a donné 
naissance à la photogrammétrie (technique permettant de réaliser des mesures spatiales à partir 
de photographies ou d’autres types d’images) 
 
En 1957, avec le lancement réussi des satellites en ex-Union Soviétique puis aux Etats-Unis en 
1958, avec en particulier, le satellite Landsat de la NASA (Etats-Unis) en 1972, l'ère d’utilisation 
paisible et d'application civile des techniques de télédétection est inaugurée. Depuis lors, divers 
capteurs optiques, des radars, mais également une variété de plates-formes, telles que le ballon, 
l'avion et le satellite ont été développés pour différentes applications. 
 
La télédétection a été ensuite largement appliquée dans de nombreux domaines : cartographie, 
géographie et géologie, inventaire des ressources naturelles, suivi de l'environnement, étude sur 
l'utilisation des sols, estimation de la productivité agricole, prévisions météorologiques, études 
sur l’atmosphère et l'océan, détection militaire, etc. 
 
 

Définition 
 
La télédétection est la technique qui, par l'acquisition d'images, permet d'obtenir de 
l'information sur la surface de la Terre sans contact direct avec celle-ci. La télédétection 
englobe tout le processus qui consiste à capter et à enregistrer l'énergie d'un rayonnement 
électromagnétique émis ou réfléchi, à traiter et à analyser l'information, pour ensuite mettre en 
application cette information. 
Elle est habituellement définie comme la science, la technologie ou l'art d'obtenir à distance des 
informations sur des objets ou des phénomènes. 
 
C'est l'utilisation à distance (par exemple, d'un avion, d'un engin spatial, d'un satellite ou encore 
d'un bateau) de n'importe quel type d'instrument permettant l'acquisition d'informations sur 
l'environnement. On fait souvent appel à des instruments tels qu’appareils photographiques, 
lasers, radars, sonars, sismographes ou gravimètres. 
 
L’on distingue en général les moyens de télédétection ‘active’ et ‘passive’ : 
- Télédétection passive : enregistrement du rayonnement naturel, fourni par la lumière ou la 

chaleur, qu’il soit émis, réfléchi ou réfracté (ex : photographies aériennes) du paysage éclairé 
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par la lumière du soleil ainsi que certaines images satellitaires comme SPOT, LANDSAT, 
IKONOS,…. 

- Télédétection active : enregistrement du rayonnement que réfléchit l’objet ou le paysage 
‘illuminé’ par l’opérateur (ex : images radar). 

 
 

Principe 
 
La méthode d'acquisition utilise normalement la mesure des rayonnements électromagnétiques 
émis ou réfléchis des objets étudiés dans un certain domaine de fréquence (infrarouge, visible, 
micro-ondes). Ceci est rendu possible par le fait que les objets étudiés (plantes, maisons, 
surfaces d'eau ou masses d'air) émettent ou réfléchissent du rayonnement à différentes 
longueurs d'onde et intensités selon leur état. 
 

 
 
Le principe de la télédétection repose donc sur l'acquisition de signaux de radiation ou de 
réflexion de l'objet, par exemple, l’utilisation des sols, par un capteur à distance installé sur 
différentes plates-formes (telles que l'avion, le satellite) en utilisant les bandes visibles, 
infrarouge et micro-onde. 
 
 

Réflectance solaire 
 
La réflectance solaire se définit comme le rapport entre l'énergie solaire réfléchie et l'énergie 
solaire incidente sur une surface (Energie Solaire Réfléchie / Energie Solaire Incidente). Par 
exemple, une réflectance de 100% signifie que la surface en question réfléchit toute l'énergie 
solaire dans l'atmosphère et n'en absorbe aucune fraction. 
 
 

Processus de télédétection 
 
A) Source d'énergie ou d'illumination : À l'origine de tout processus de télédétection se trouve 
nécessairement une source d'énergie pour illuminer la cible. 
 
B) Rayonnement et atmosphère : Durant son parcours entre la source d'énergie et la cible, le 
rayonnement interagit avec l'atmosphère. Une seconde interaction se produit lors du trajet 
entre la cible et le capteur. 
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C) Interaction avec la cible : Une fois parvenue à 
la cible, l'énergie interagit avec la surface de 
celle-ci. La nature de cette interaction dépend 
des caractéristiques du rayonnement et des 
propriétés de la surface. 
 
D) Enregistrement de l'énergie par le capteur : 
Une fois l'énergie diffusée ou émise par la cible, 
elle doit être captée à distance (par un capteur 
qui n'est pas en contact avec la cible) pour être 
enfin enregistrée. 

 
E) Transmission, réception et traitement : L'énergie enregistrée par le capteur est transmise, 
souvent par des moyens électroniques, à une station de réception où l'information est 
transformée en images (numériques ou photographiques). 
 
F) Interprétation et analyse : Une interprétation visuelle et/ou numérique de l'image traitée est 
ensuite nécessaire pour extraire l'information que l'on désire obtenir sur la cible. 
 
G) Application : La dernière étape du processus consiste à utiliser l'information extraite de 
l'image pour mieux comprendre la cible, pour nous en faire découvrir de nouveaux aspects ou pour 
aider à résoudre un problème particulier. 
 
 

Objectifs et utilisations de la télédétection 
 
L'objectif principal de la télédétection est de cartographier les ressources terrestres et d'en 
effectuer le suivi. Par rapport aux techniques de levée classiques, la télédétection par satellite 
est précise et rentable, et permet d'obtenir des données en temps utile. La télédétection est 
utilisée pour la gestion des ressources dans les domaines de la géomorphologie, l’urbanisme, le 
climat, la végétation, l’agriculture, etc. 
 
Le principal avantage est que les observations faites par télédétection contribuent à la gestion 
intégrée de l'environnement et des ressources naturelles, car l'environnement et tout ce qu'il 
renferme peuvent être observés comme un seul et même système. 
 
Par ailleurs, pour prévoir certains phénomènes, des modèles numériques doivent être mis au point 
et validés pour fournir une opinion extrapolée des tendances futures. Les données issues de la 
télédétection et des observations in situ sont ensuite entrées dans des modèles pour produire 
des prévisions de la situation réelle. 
 
Les applications terrestres de la télédétection sont donc extrêmement variées et sont utilisées 
dans plusieurs disciplines scientifiques telles que la cartographie, l'agriculture, la géologie, 
l'hydrologie, la météorologie et l'océanographie, la prospection minière, mais aussi la surveillance 
des cultures ou du couvert forestier, l’urbanisme, l’aménagement, le génie civil, etc. 
 
De nombreux logiciels  de traitement d’image satellitaire existent : ERDAS, ENVI, etc… Ce cours 
se concentre sur les fonctions de base les plus utilisées du logiciel ENVI. 
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Chapitre 2 
ENVI Zoom 
 

 
ENVI Zoom est une version simplifié d’ENVI spécialement conçue pour afficher et manipuler plus 
facilement et plus efficacement les images satellitaires, photographies aériennes : outils de 
zoom, contraste, transparence, brillance, projection et rééchantillonnage des données au 
vol,….Dans cette section, vous allez découvrir les possibilités qu’offre ENVI Zoom pour visualiser 
des données géographiques (image et vecteur). 
 
 

Ouvrir un fichier dans ENVI Zoom 
 
Démarrez Envi Zoom en cliquant sur l’icône sur le bureau : 
 
On peut procéder de deux manières : 
 
Cliquez sur l’icône Open (une farde jaune entre-ouverte) 
 

 
 
Puis naviguez jusqu’aux fichiers d’intérêt et ouvrez les : 
 
C:\Formation_ENVI\Input\Kou_19860116 
C:\Formation_ENVI\Input\Kou_20070110 
 
Les images apparaissent dans le Viewer d’ENVI Zoom. 
 
Ou 
 
Cliquez sur File → Open puis naviguez jusqu’aux fichiers d’intérêt. 
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Interface d’ENVI Zoom 

 
A l’aide de la section suivante, découvrez les possibilités de visualisation qu’offre ENVI Zoom 
avec ces 2 fichiers images. Répondez aux questions posées à la suite de cette section. 
 

 
 
L’interface d’ENVI Zoom s’organise de la manière suivante : 
 
 Le viewer: visualisation des données géographiques qui sont activées dans l’onglet Layer 

Manager du panneau latéral ; 
 Les barres de menus et d’outils: accès aux fonctionnalités d’ENVI Zoom ; 
 Le panneau latéral : résumé des images ouvertes. 
 
 

Barre de menu 
 

 
 

  
 
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 File : permet notamment d’ouvrir un fichier, d’accéder au Data Manager, d’accéder à des 
données sur internet, de sauver un fichier, de démarrer ENVI et de modifier vos 
préférences. 

 Edit : commande la disposition et affichage des couches, via l’onglet Layer Manager du 
panneau latéral (undo/redo, remove, order). 

 Display: permet d’activer les options de visualisation Portal, Blend,Flicker, Swipe. Un ‘Portal’ 
est une petite fenêtre qui vient s’ajouter dans la fenêtre du viewer principal, et qui permet de 
visualiser simultanément plusieurs couches superposées. Le ‘Portal’ se présente comme un bloc 
de données indépendant dans le Layer Manager du panneau latéral. 

 Processing : diverses opérations à réaliser sur image. 
 Help : l’aide. 
 
 

Barres d’outils 
 

 
 
 Data Manager : liste et donne des informations sur les fichiers précédemment ouverts, et 

permet de les charger dans le Layer Manager. 
 Do / undo, select, crosshairs, sauver la vue. 
 Outils de déplacement (main, vol) et de zoom (interactif ou automatique). 
 Outils de création et édition vectorielle (désactivés en absence de couche vectorielle). 
 Outils de rotation de l’image (interactif ou automatique). 
 

 
 
 Options de visualisation simultanée de différentes couches : Portal, Blend, Flicker, Swipe. Un 

swipe doublé d’une rotation continue est du plus bel effet ! 
 

 
 
 Go To : pour zoomer sur des coordonnées (pixel, géographiques ou carte). 
 Brillance, Contraste, Amélioration de contraste (méthode prédéfinie ou interactive), sharpen, 

transparence. 
 
 

Panneau latéral 
 
 Overview: positionne l’étendue de la vue du viewer principal par rapport à l’étendue maximale 

définie par le groupe d’images actives dans le Layer Manager. 
 Layer Manager: se compose de 2 fardes ou ‘bloc de données’ indépendant : 
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a) La farde Layers permet d’activer (show), d’organiser (order), supprimer, zoomer sur les 
couches. (Similaire à la table des matières d’ArcMap) ; 

b) La farde Portals : voir ci-dessus. 
 Cursor Value: donne toute une série d’information sur le pixel ‘sélectionné’ pour les 

différentes couches apparaissant dans le viewer principal: nom de la couche, système de 
coordonnées de la couche, coordonnées du pixel(fichier, carte, géographiques), valeur du pixel. 

 

 
 
 

Exercice 
 
Quelles différences remarquez-vous entre les deux fichiers ? Comment sont-ils structurés ? 
 
L’ajout d’un fichier vectoriel, active les outils d’édition / création vectorielle. Testez les divers 
outils d’édition / création. Créez par exemple les ‘Zones d’occupation’. Ne sauvez pas vos 
modifications. 
 
Accédez aux informations attributaires du fichier vectoriel. Elles s’affichent dans la fenêtre 
‘Cursor Value’ du panneau latéral lorsque vous sélectionnez une entité vectorielle à l’aide de la 
flèche de sélection. 
 
Nous allons utiliser à présent les fonctions swipe et flirt pour comparer l’image Landsat de 10 
janvier 2007 et une image SPOT5 de haute résolution datant du 11 janvier 2007. 
 
Ouvrez successivement avec ENVI Zoom les fichiers Kou_20070110 et SPOT5_20071211 
situés dans le répertoire C:\Formation_ENVI\Input\. 
 
On obtient la présentation suivante : 
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Cliquez successivement sur les boutons Portal, Blend, Flicker, Swipe pour observer les 
différentes modifications. 
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Chapitre 3 
Exploration d’images de télédétection 
 

 
L’objectif de ce chapitre est de : 
1. Comprendre la nature et le mode d’organisation de données de télédétection ; 
2. Comprendre et déterminer le comportement spectral de quelques unités d’occupation du sol ; 
3. Comprendre et utiliser l’histogramme bidimensionnel pour une classification rapide de l’image ; 
4. Calculer l’indice de végétation NDVI à partir de l’image Landsat ETM 7+ et déterminer les 
valeurs prises par cet indice pour quelques unités de paysage. 
 
 

Présentation du logiciel RSI ENVI 
 
ENVI est un logiciel complet de traitement d’images de télédétection, optiques et radar. Toutes 
les méthodes de traitement d’images de corrections géométriques et radiométriques, de 
classification et de mise en page cartographique sont présentes. D’autres outils relatifs à la 
visualisation et à la modélisation de données topographiques sont aussi disponibles. Le logiciel 
ENVI est conçu en langage IDL (Interactive Data Langage) et offre donc des moyens de 
programmation évoluée. Il a été conçu et développé par ITT Visual Information Solutions. 
 
ENVI permet d’extraire rapidement l'information pertinente des images géospatiales. 
L'ensemble de ses outils et modules spécialisés permettent de lire, explorer, analyser les 
données et de partager l'information. Avec une interface Windows, il est facile d’utilisation. 
 
Le logiciel ENVI  offre des fonctionnalités des systèmes de traitements interactifs de données 
numériques géocodées (données satellitaires, images numérisées, cartes digitalisées,….). Avec ses 
options, Envi propose un environnement de traitement, d’archivage et de consultation d’images 
sur PC et de nombreuses fonctions de transformation pour SIG. Des programmes de liaison 
Import-Export permettent l’intégration des données avec d’autres logiciels fondamentaux de 
SIG, CAO, DAO. 
 
 

Lancement d’ENVI 
 
Lancez le logiciel par Démarrer → Programmes →ENVI 
 
Ou double-cliquez l’icône d’Envi sur le bureau 
 
Naviguez à travers le menu principal d’Envi pour examiner les différents menus et sous menus 
disponibles. 
 
 

Organisation d’images de télédétection 
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Les images de télédétection sont en mode RASTER et fournies sous différents formats. Certains 
sont propres aux satellites concernés et contiennent les données brutes (SPOT, Landsat, 
IKONOS,NOAAH, etc...), d’autres sont spécifiques aux logiciels de télédétection les plus connus 
(format LAN et img d’Erdas, PCI de PCI, BIL d’ArcGIS, etc...). 
 
Dans le mode RASTER, l’espace est divisé en unités spatiales élémentaires. Cette unité spatiale 
élémentaire est appelée pixel (Picture element). La taille en unités de distance de ce pixel définit 
la résolution spatiale de l’image. 
Un fichier RASTER peut être constitué d’un ou plusieurs plans. Une image couleur en mode RVB 
(Rouge, Vert, Bleu) contient trois plans de couleurs. En 8 bits, chaque plan de couleur correspond 
à des teintes variant de 0 à 255. 0 étant du noir et 255 est la couleur pure (blanche). La 
combinaison de trois valeurs 0 pour chaque plan produit une teinte noire. Au contraire, une teinte 
blanche est produite par combinaison de trois valeurs identiques de 255 pour les trois plans 
rouge, vert et blanc.  
Les images satellites peuvent contenir de nombreux plans. Chaque plan image correspond à une 
bande spectrale précise, c'est-à-dire à une longueur d’onde dans laquelle l’image a été acquise.  
 
Les fichiers raster utilisés dans des applications SIG et de télédétection ne contiennent pas un 
niveau de couleur mais des informations quantitatives mesurées : rayonnement réfléchi ou un 
signal radar rétrodiffusé pour les images issues de la télédétection passive et radar, la 
profondeur de la nappe phréatique pour les cartes piézométriques, l’altitude pour les cartes 
topographiques. Selon les logiciels, les références spatiales sont soient enregistrées dans les 
entêtes de l’image (*.img de Erdas Imagine, DEM) soit dans un fichier séparé (le fichier *.hdr 
Header pour ENVI). 
 
Une image de télédétection est le plus souvent constituée de plusieurs couches. Chaque couche 
correspond à un intervalle de longueur d’onde bien précis. Pour chaque pixel de l’image, deux 
informations sont disponibles et ne doivent en en aucun cas être confondues : l’information 
couleur qui ne sert que pour l’affichage et l’information radiométrique qui correspond à une 
mesure physique. 
Un logiciel de télédétection distingue entre ces deux types d’informations. Au contraire, un 
logiciel de traitement de photos numériques ne considère que l’information couleur. Une image de 
télédétection enregistrée sous un format grand public (bmp, tiff, jpg, gif, …) ne contient qu’une 
information couleur et perd donc tout son intérêt. 
 
 

Ouverture d’une image 
 
Dans le menu principal cliquez sur File →Open image file 
 

 
 
 
Naviguez jusqu’au fichier C:\Formation_ENVI\Input\Kou_20001216. 
 
Cliquez sur Ouvrir. 
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Kou_20001216 est un extrait d’une image Landsat acquise le 16 décembre 2000. Il s’agit en fait 
d’une image corrigée géoréférencée dans le système de coordonnées UTM WGS 84. Cette image 
est constituée de 8 bandes avec les longueurs d’ondes correspondantes suivantes : 
 

Gamme de 
bandes 

(micro m) 

Localisation 
spatiale 

Résolution 
(m) 

Swath 
(km) 

Application principale 

B1 : 0.45-0.52 Bleu 30x30 185 Pénétration des plans d’eau, 
cartographie des eaux territoriales 

B2 : 0.52-0.60 Vert 30x30 185 Distinction de la végétation, évaluation 
de la vigueur et identification des 
différents types de cultures 

B3 : 0.63-0.69 Rouge 30x30 185 Absorption de la chlorophylle, et 
différenciation des espèces végétales 

B4 : 0.76-0.90 Proche IR 30x30 185 Détermination des types de 
végétation et surveillance de la 
vigueur et de la biomasse, définition 
des limites des plans d’eau 

B5 : 1.55-1.75 Moyen IR 30x30 185 Indicateurs de végétation et 
d’humidité du sol utilisés pour la 
différenciation de la neige et des 
usages 

B6 : 10.4-12.5 IR therm. TM 120x120 
ETM+ 60x60 

185 Analyse des contraintes de 
végétation, distinction de l’humidité du 
sol et cartographie thermique 

B7 : 2.08-2.35 Moyen IR 30x30 185 Identification des types de roches et 
de minéraux, cartographie 
hydrothermale et mesure de 
l’humidité du sol et de la végétation 

B8 : 0.50-0.90 Visible et 
proche IR 

15x15 185 Image à la résolution plus élevée 

Source: WU, 2003; http://landsat.gsfc.nasa.gov/images/ 
 
La boîte de dialogue Available Bands List affiche le nombre de couches que constitue l’extrait 
de l’image Landsat de décembre 2000 et de l’information sur la projection de l’image. 
 
Développez le + devant Map Info pour visualiser ces informations. 
 
Ici, on a donc 8 couches, nommées B10, B20, B30, B40, B50, B60, B70.La bande B_80 possède 
une résolution de 15mx15m, mais n’est pas dans la liste ci-dessus mentionnée. 
 

http://landsat.gsfc.nasa.gov/images/
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Deux modes de visualisation de l’image sont disponibles : GrayScale (échelle de gris) et RGB 
(rouge, vert et bleu). L’image résultante de ce dernier mode d’affichage est dite composition 
colorée ou image en fausse couleur du fait que les bandes disponibles ne correspondent pas 
réellement aux couleurs primaires. 
 
 

Affichage en niveaux de gris 
 
Cliquez sur la bande *_B30. 
Choisissez le mode d’affichage Gray Scale 
Cliquez sur le Bouton Load Band. 
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Trois fenêtres s’ouvrent : la fenêtre principale Display, le Scroll et le Zoom. 
 

 
 
Le carré rouge sur la fenêtre Scroll permet de délimiter la zone géographique qui s’affichera sur 
la fenêtre Display ; et le carré rouge dans la fenêtre Display permet de délimiter la zone 
géographique qui s’affichera sur la fenêtre Zoom. 
 
Ces fenêtres peuvent être agrandies ou réduites à l’aide de la souris. 
 
Le mode de visualisation en niveaux de gris n’affiche qu’une seule bande. Le niveau de gris varie 
entre 0 et 255. 0 correspond au noir et 255 au blanc. Plus le pixel est sombre, plus sa 
réflectance est faible. 
 
De la même manière que pour la bande  *_B30, visualisez les autres bandes (B40, B20, etc…20 et 
10). 
 
Cliquez sur le bouton Display de la boîte de dialogue Available Bands List puis New Display 
(nouvelle fenêtre) et de nouveau Load Band. 
 
Essayer de trouver la zone de la Guinguette. Dans le proche Infrarouge, on remarque que les 
forêts apparaissent dans des teintes grises plus ou moins claires et inversement dans les deux 
autres bandes spectrales. 
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De gauche à droite : proche infrarouge, rouge et vert. (B40, B30, B20) 
 
 

Affichage en vraies et fausses couleurs : composition colorée 
 
L’affichage en fausses couleurs consiste à attribuer des couleurs fictives aux bandes spectrales. 
L’image résultante est dite composition colorée et se compose de trois plans de couleur rouge, 
vert et bleu (RGB). Par convention, on attribue la couleur rouge à la bande spectrale proche 
infrarouge, la couleur verte à la bande rouge et la couleur bleue à la bande verte. 
 
Validez l’option RGB dans la boîte de dialogue Available Bands List 
Puis attribuez la couleur correspondante à chacune des bandes : sélectionnez d’abord le rouge, 
après cliquez sur la bande B40 et la bande apparaîtra derrière le bouton R. 
Faites pareilles pour G et B en utilisant les bandes B30 et B20. 
 

 
 
Puis cliquez sur Load RGB. On obtient l’écran suivant. 
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Dans une composition et comme pour toute image couleur, la formation de la couleur est basée 
sur les trois couleurs primaires Rouge, Vert et Bleu. En mode dit synthèse trichromatique 
additive, on part du noir (absence de couleur), on ajoute dans des proportions variables les trois 
couleurs primaires pour former de la couleur. Par exemple, le blanc est formé par les trois 
couleurs R, V et B à intensités maximales (255). 
 
D’une manière générale, sur une composition colorée, les sols nus apparaissent dans des teintes 
bleu clair, l’eau dans une teinte bleu foncé ou pratiquement noir, la végétation herbacée en rouge 
clair, les forêts feuillues en rouge foncé et les résineux dans des teintes rouge-noir. 
Il est important de signaler que ces remarques sont données à titre indicatif. Différents 
facteurs en particulier l’état d’humidité du sol et le tapis herbacé en forêts  peuvent être à 
l’origine d’une forte modification de la réflectance du pixel. 
 
Pour examiner les valeurs des pixels, cliquez dans la fenêtre Display sur Tools → Cursor 
Location/Value. 
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Une nouvelle fenêtre s’ouvre. 
 

 
 
Marquez avec le pointeur de la souris sur l’image et constater le changement des valeurs. 
 
Exemple d’information fournie par Cursor Location / Value : 

Disp: 5786 – 4939 : coordonnées du curseur en nombre de colonnes, nombre de lignes. 
Scrn: R, G, B valeurs couleur du pixel. Ces valeurs ne servent qu’à l’affichage. 
Projection : UTM, Zone 30 Nord : système de projection. 
MAP : X, Y UTM du curseur en m. 
LL : Latitude – Longitude  
Data : R, G, B : valeurs de la luminance du pixel. 

 
Cliquez sur File de la fenêtre Available Band List puis sur Close All Files pour fermer tous 
les fichiers ouverts. 
 
Quittez complètement ENVI à partir du menu principal d’Envi en cliquant sur File → Exit.  
 
 

Signatures spectrales 
 
Le but de cette section est de déterminer des profils spectraux de différentes unités 
d’occupation du sol. Il s’agit de déterminer les différentes valeurs de la luminance (niveaux de 
gris) pour chacune des principales unités de paysage : sols nus, cultures, eau, forêts, …. 
 
Démarrez ENVI. 
 
Ouvrez l’image Kou_20070110 situé dans le répertoire c:\Formation_ENVI\Input. 
 
Puis chargez l’image en RGB. 
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Dans le menu Tools de la fenêtre Display, cliquez sur l’outil Spectral Pixel Editor : 
 

 
 
Faites en sorte que l’écran soit organisé comme ci-dessous en glissant les différentes fenêtres : 
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Ouvrez également le Pixel Locator. 
 

 
 
A l’aide de l’outil Pixel Locator aller sur une forêt (Guinguette). 
 

 
 
Dans la boite de dialogue de Pixel Locator choisissez pour Sample = 518 et Line= 663. 
 
Puis cliquer sur Apply pour se positionner sur la forêt de la Guinguette. 
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Utilisez la fenêtre Zoom pour bien localiser le curseur sur l’image (+, -). 
 
Une fois, l’entité du paysage (Guinguette) est choisie, dans le menu Edit de la boîte de dialogue 
Spectral Pixel Editor, utilisez Extract 8 pixel average (ou 4, 2) selon les dimensions de l’unité 
afin d’extraire une valeur moyenne de la luminance dans chacune des bandes. 
 

 
 
La signature spectrale s’affiche dans un graphique du Spectral Pixel Editor. 
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Allez vers une surface d’eau à l’aide du Pixel Locator (Eau de Suo), Sample=415, Line=365. 
 

 
 
De nouveau dans la fenêtre Spectral Pixel Editor cliquez Extract 8 pixels. 
 
Une deuxième ligne s’ajoute. 
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Répétez maintenant l’opération pour sols nus et autres minéraux (sols faiblement couverts) : 
Sample=589, Line=500 
 
Choisissez Extract 4 pixel average. 
 

 
 
Répétez maintenant l’opération pour l’agriculture (culture et prairies) en utilisant Pixel 
Locator : Sample=489, Line= 389. 
 
Choisissez Extract 2 pixel average. 
 

 
 
Une fois ces opérations terminées, déterminez pour chacune des unités étudiées, un profil type. 
 
Cliquez à l’aide du bouton droit de la souris dans la fenêtre graphique pour afficher la légende 
en cliquant sur le menu Plot Keys. 
 

 
 
Une légende s’affiche à droite de la graphique. 
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Dans le menu Edit, cliquez sur Data Parameters et donnez des noms thématiques à chacune 
des courbes. 
 

 
 
Cliquez dans la case en face de Name et donnez les noms convenables : 

- Guinguette 
- Eau (Suo) 
- Sols nus 
- Cultures et prairies 

 

 
 
Après avoir changé tous les noms cliquez sur Apply pour appliquer. 
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Fermez Data Parameters. 
 
On obtient comme graphique : 
 

 
 
Utilisez ensuite dans le menu File de la fenêtre Spectral Pixel Editor l’option Save Plot As → 
Image File. 
 

 
 
La boite Output Plot to Image File s’ouvre. 
 
Au niveau de Output File Type choisissez BMP. 
 
Cliquez  sur le bouton Choose pour choisir le répertoire et enregistrez le fichier sous le nom 
Signatures_spect.bmp dans C:\Formation_ENVI\Output. 
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Insérez ensuite cette figure dans un fichier Microsoft Word. 
 
La figure suivante montre quelques profils spectraux déterminés sur certaines entités du 
paysage. On remarque que les signatures sont bien différentes dans les bandes 1 et 2. Ces 
différences typiques pour ces occupations nous aideront à classifier facilement l’image. 
 

 
Bande 1 : R = proche infra-rouge 
Bande 2 : V = rouge 
Bande 3 ; B = vert 
 
Quittez ENVI 
 
 

Histogramme bidimensionnel et classification 
 
L’histogramme bidimensionnel exprime la distribution de tous les pixels de l’image dans le plan 
constitué, par exemple, par le rouge en abscisse et le proche infrarouge en ordonnée. Ces deux 
bandes sont celles où on observe un contraste important entre les différentes unités du paysage, 
comme constaté dans les profils spectraux. 
 
L’outil 2D scatter plot permet d’examiner la relation entre les valeurs de pixels dans les deux 
bandes sélectionnées et également la distribution spatiale dans l’image des pixels dans n’importe 
quel endroit du scatter plot. 
 
Démarrez ENVI. 
Ouvrez l’image Kou_20070110 situé dans le répertoire C:\Formation_ENVI\Input\. 
Puis chargez l’image en RGB. 
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Dans le menu Tools de la fenêtre Display, cliquez sur l’outil 2D-Scatter Plots. 
 

 
 
Sélectionnez B30 pour X et B40 pour Y, et cliquez sur OK. 
 

 
 
La boite du Scatter Plot apparait. 
 

 
 
Dans le Display, faites bouger le curseur en gardant le bouton gauche enfoncé. 
 
Des points rouges s’affichent dans le  Scatter Plot correspondant aux valeurs de réflectance 
Infra Rouge et Rouge. 
 
Cliquez sur différents endroits ou occupations sur l’image et remarquez leurs positions dans le 
Plot. 
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Dans la fenêtre Scatter Plot, utilisez l’outil Options → DensitySlice. 
 

 
 
Cette option permet d’afficher la distribution des densités de pixels dans le repère rouge, 
proche infrarouge. L’histogramme affiche la distribution des pixels de la fenêtre Display. En 
changeant la zone affichée dans la fenêtre Display, partie du rectangle rouge dans le Scroll 
l’histogramme va être aussi modifié. 
 
Désactivez le Density Slice avant de poursuivre. 
 
On va positionner différentes unités du paysage sur le plan rouge, proche infrarouge. Des 
exemples de données à utiliser à l’aide du Pixel Locator : 

Guinguette Sample=518, Line=663 
Eau  Sample=413, Line=366 
Sols nus Sample=589, Line=500 
Agriculture Sample=489, Line= 389 

 
Dans le menu Class → New Items 1:20→…, choisissez une couleur autre que le blanc. 
 

 
 
Cliquez et faites bouger le curseur sur le Zoom dans la zone de la Guinguette. 
 
Observer quelles zones se colorent dans le Scatter Plot. 
 
Ensuite, dans le Scatter Plot, à l’aide de la souris dans la zone correspondant à la Guinguette, 
tracez un polygone en cliquant à l’aide de la souris (bouton gauche) de nombreuses fois autour 
d’une petite zone de l’histogramme bidimensionnel. Faites bouton droit pour fermer le polygone. 
 
Remarquez que dans le Display et le Zoom, les zones ayant les mêmes caractéristiques spectrales 
que la Guinguette s’affichent en vert. 
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Pour faire cette opération sur plusieurs différentes zones : 
 
Déplacez la fenêtre du Zoom vers une autre région, faites-vous guider par le Pixel Locator. 
 
Dans le Scatter Plot, cliquez Class → New 
 
Choisissez une autre couleur pour chaque zone. 
 
Utilisez les outils Options → Clear Class ou Clear All pour effacer les classes indésirables. 
 
Remarquez les classifications dans le Display : vert pour forêt, blue pour eau, jaune pour sols nu 
et rouge pour agriculture. 
 
Il est important de rappeler que l’outil 2D scatter plot permet d’examiner la relation entre les 
valeurs de pixels dans de deux bandes sélectionnées et également la distribution spatiale dans 
l’image des pixels dans n’importe quel endroit du scatter plot. 
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Dans le menu Options de la fenêtre Scatter plot, cliquer sur Mean all pour déterminer les 
moyennes dans les trois bandes de chaque zone de l’histogramme bidimensionnel. 
 

 
 
Sélectionnez le fichier Kou_20070110 et cliquez sur OK. 
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Une fenêtre Scatter Plot Mean s’affiche indiquant les moyennes dans les trois bandes. 
 

 
 
Comme pour les courbes issues de l’outil Spectral Editor, modifiez la légende du graphique et 
l’insérez ensuite dans le même fichier Word. 
 
Quittez Envi 
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Chapitre 4 
Classifications d’images 
 

 
 
Les méthodes de classification les plus communes peuvent être séparées en deux grandes 
catégories : les méthodes de classification supervisée et les méthodes de classification non 
supervisée.  
 
La classification non supervisée procède de la façon contraire. Les classes spectrales sont 
formées en premier, basées sur l'information numérique des données seulement. Ces classes sont 
ensuite associées, par un analyste, à des classes d'information utile (si possible). Des 
programmes appelés algorithmes de classification sont utilisés pour déterminer les groupes 
statistiques naturels ou les structures des données. 
Habituellement, l'analyste spécifie le nombre de groupes ou classes qui seront formés avec les 
données. De plus, l'analyste peut spécifier certains paramètres relatifs à la distance entre les 
classes et la variance à l'intérieur même d'une classe. 
Le résultat final de ce processus de classification itératif peut créer des classes que l'analyste 
voudra combiner, ou des classes qui devraient être séparées de nouveau. Chacune de ces étapes 
nécessite une nouvelle application de l'algorithme. L'intervention humaine n'est donc pas 
totalement exempte de la classification non supervisée. Cependant, cette méthode ne commence 
pas avec un ensemble prédéterminé de classes comme pour la classification supervisée. 
Il s’agit de la technique le plus rapide, mais le moins exact vu qu’il n’existe pas de contrôle avec 
des connaissances du terrain.  
 
Lors de l'utilisation d'une méthode de classification supervisée, l'analyste identifie des 
échantillons assez homogènes de l'image qui sont représentatifs de différents types de surfaces 
(classes d'information). Ces échantillons forment un ensemble de données-tests. La sélection de 
ces données-tests est basée sur les connaissances de l'analyste, sa familiarité avec les régions 
géographiques et les types de surfaces présents dans l'image. L'analyste supervise donc la 
classification d'un ensemble spécifique de classes. 
Les informations numériques pour chacune des bandes et pour chaque pixel de ces ensembles 
sont utilisées pour que l'ordinateur puisse définir les classes et ensuite reconnaître des régions 
aux propriétés similaires à chaque classe. L'ordinateur utilise un programme spécial ou 
algorithme afin de déterminer la ‘signature’ numérique de chacune des classes.  
Plusieurs algorithmes différents sont possibles. Une fois que l'ordinateur a établi la signature 
spectrale de chaque classe à la classe avec laquelle il a le plus d'affinités. Une classification 
supervisée commence donc par l'identification des classes d'information qui sont ensuite 
utilisées pour définir les classes spectrales qui les représentent. 
Il s’agit de la technique le plus rapide, mais le moins exact vu qu’il n’existe pas de contrôle avec 
des connaissances du terrain.  
 
Dans cette partie, on testera les différentes méthodes de classification des images. On 
commencera par l’image Kou_20001216. 
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Classification non supervisée 

 
On distingue deux méthodes de classification non supervisée sous Envi : 
 La méthode de K-Mean : Regroupement des pixels de l’image au centre de classes, 

régulièrement distribués dans l’hyperespace, les plus probables (statistiques).Elle permet une 
analyse régionale des grands types homogènes de couvertures végétales. 

 La méthode de classification non supervisée en valeurs égales (Isodata) : Regroupement des 
pixels de l’image aux centres des classes, régulièrement distribués dans l’hyperespace, les 
plus proches (distance). 

 
Démarrer le logiciel Envi et chargement du fichier 

 
Double-cliquez sur le raccourci d’Envi sur le bureau pour lancer l’application. 
Ou 
Cliquez sur le menu Démarrer → Programme → Envi 4.5 →ENVI 
 
Dans le menu fichier (File), sélectionnez la commande Open Image file 
 
La boite de dialogue Enter Data File Names apparaît. 
 
Naviguez jusqu’au répertoire ‘C:\Formation_ENVI\input’ et sélectionner le fichier 
‘Kou_20001216_432’. 
 
Chargez l’image de la manière suivante : Bande 4 = Red, Bande 3 = Green et Bande 2 = Blue 
 

 
 
Pour une cartographie de l’occupation du sol ; l’examen de l’image permet de détecter les classes 
suivantes : 

1. Sols nus et autres minéraux (couleur bleu clair, blanc) 
2. Sols faiblement couverts (bleu-vert) 
3. Cultures et prairies (rose) 
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4. Surfaces d’eau libre (bleu ou noir selon essentiellement la profondeur et la nature des 
fonds). 

5. Forêts (rouge sombre). 
 

Classification ‘ISO data’ 
 
Dans le menu principal ENVI, cliquez sur Classification → Unsupervised → Isodata. 
 

 
 
Cliquez sur le nom de la composition colorée dans la boite de dialogue Classification Input file. 
Laissez les informations par défaut puis appuyez sur OK. 
 

 
 
Une autre boite de dialogue dénommée ISODATA Parameters apparait.  
 

 
 
Nombre de classes : 5 à 10 
Nombre d’itérations : 10 
Seuil ou critère d’arrêt : 5% 
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Laissez les autres options par défaut. 
Le seuil de 5% signifie que la classification par la méthode Isodata est terminée lorsqu’un 
nombre de pixels ≤ 5% change de classe entre les itérations n-1 et n. Ceci signifie qu’un nombre 
d’itérations supérieur n’apporte qu’une légère amélioration de la classification finale. Plus ce seuil 
est petit plus la classification est précise. 
 
Cliquez sur le bouton Choose de Enter Output filename afin de pouvoir nommer le fichier. 
 
Donnez le nom ‘ClassIso_Kou_20001216’ 
 
Puis naviguez au répertoire ‘C:\Formations_ENVI\Output’ et cliquez OK pour lancer la 
classification. 
 

 
 
Le fichier de classification apparait dans Available Bands List dans l’option Gray Scale.  
 

 
 
Sélectionnez-le et cliquez sur Load pour le charger. 
 
On obtient l’image suivant : 
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Affichez également la composition colorée dans une autre vue : Display 2 
 
Cliquez sur RGB puis charger le fichier Kou_20001216de la façon suivante : 

R : Band 4 
G : Band 3 
B : Band 2 
 

Choisissez New Display puis cliquez sur Load. 
 
Disposez les deux vues côte à côte de la manière suivante. 
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Utilisez l’outil Tools → Link → Link Displays pour déterminer la correspondance entre les 
couleurs et les classes. 
 

 
 
Dans la boite de Link Displays mettez tous les displays sur Yes et Dynamic overlay sur On. 
 

 
 
Affectez ensuite des noms aux classes. 
 
Dans la fenêtre montrant l’image classée, cliquez sur Tools → Color mapping → Class Color 
Mapping. 
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La boite de dialogue Class Color Mapping apparaît. 
 

 
 
Cliquez sur la classe 1, comparez la couleur de la classe et les couleurs de l’image classée et 
l’image composée (voire aussi directives page 31). 
 
Des localisations des classes sont présentées afin de vous guider à partir du pixel Locator : 
 

Classe 1 :  Eau Sample=414 ;   Line =362 
Classe 2 :  Sols faiblement couverts Sample=585 ;  Line=500 
Classe 3 :  Forêt Sample=521 ;   Line=656 
Classe 4 :  Sols faiblement couverts2 Sample=603 ;  Line=397 
Classe 5 :  Savane Sample=595 ;  Line=740 
Classe 6 :  Sols nus Sample=611 ;   Line=406 
Classe 7 :  Savane2 Sample=595 ;  Line=761 
Classe 8 :  Savane3 Sample=177 ;   Line=67 
Classe 9 :  Sols nus2 Sample=610 ;   Line=421 
Classe 10 :  Cultures et prairies Sample=473 ;  Line=355 

 
Ecrivez le nom de la classe sous Classe Name et taper Enter pour confirmer. 
Sélectionnez la classe suivante et puis continuez pour toutes les classes. 
 
Si une classe est rencontrée une deuxième fois, ajoutez à la classe un autre indicateur : par 
exemple classe Sols faiblement couverts lorsque la classe est rencontrée une première fois, 
ensuite Sols faiblement couverts2 lorsqu’elle est rencontrée une deuxième fois. 
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Une fois, l’affectation est terminée, cliquez Options → Save changes pour valider. 
 

 
 

Combinaison des classes 
 
Dans le menu principal ENVI Classification, cliquez sur Post Classification → Combine 
classes. 
 

 
 
La boite de dialogue Combine Classes Input File s’ouvre et choisissez le fichier 
ClassIso_Kou_20001216 puis cliquez OK. 
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Une autre boite de dialogue (Combine Classes Parameters) s’ouvre. 
 
Remplissez la boite selon les informations ci-dessous : 
 

Input class Output class 
Unclassified → Unclassified 
Eau → Eau 
Sols faiblement couverts → Sols faiblement couverts 
Forêt → Forêt 
Sols faiblement couverts2 → Sols faiblement couverts 
Savane → Savane 
Sols nus → Sols nus 
Savane2 → Savane 
Savane3 → Savane 
Sols nus2 → Sols nus 
Cultures et prairies → Cultures et prairies 

 
Cette étape permet de combiner plusieurs classes. Dans notre cas ici les classes dénommées 
‘Unclassified’, ‘Eau’, ‘Forêt’ et ‘Cultures et prairies’ ne seront pas modifiées. 
Mais la classe de ‘Sols faiblement couverts2’ sera ajoutée à la classe ‘Sols faiblement couverts’. 
Les classes ‘Savane2’, ‘Savane3’ seront ajoutées à la classe ‘Savane’; la classe ‘Sols nus2’ sera 
ajouté à la classe ‘Sols nus’. 
 
Sélectionnez ‘Eau’ dans Select Input Class et Select Output Class, et confirmez par Add 
Combination. 
 
Faites pareil pour toutes les autres class dans Select Input Class. 
 
Attention de combiner par exemple Savane2 avec Savane afin de pouvoir combiner ces classes. 
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Une fois terminée, cliquez sur OK. 
 
La boite de dialogue Combine Classes Output s’ouvre. 
 

 
 
Retirez Emply classes (classes vides) : Yes en cliquant sur les deux (2) flèches. 
 
Enregistrez le résultat sous le nom Classiso_Kou_20001216comb dans le répertoire 
C:\Formation_Envi\Output. 
 
Le nouveau fichier apparaît dans la boite de dialogue Available Bands List. 
 

 
 
Ouvrez-le dans un troisième Display. 
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La nouvelle classification est la suivante : 
 

 
 
Ouvrez la boite de dialogue Class Color mapping à partir de l’outil Tools → Colors Mapping → 
Class Color mapping de l’image classifiée. 
 
Modifiez les couleurs d’affichages des classes, par exemple ‘Eau’ devient bleu. 
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Statistique des classes 
 
Dans le menu principal ENVI Classification cliquez sur Post Classification → Class Statistics 
pour calculer les statistiques des classes. 
 

 
 
La boite de dialogue Classification Input File s’ouvre. 
Sélectionnez le fichier et cliquez OK. 
 

 
 
Dans la boite Statistics Input File sélectionnez de nouveau le fichier et cliquer sur OK. 
 

 
 
Choisissez toutes les classes en cliquant sur le bouton Select All Items puis cliquez sur OK. 
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Dans la boîte Compute Statistics Parameters, cliquez sur OK. 
 

 
 
Les résultats statistiques s’affichent comme suite : 
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Ou, Class Distribution Summary : 
 

Unclassified: 0 points (0.000%) (0.0000 Meters²) 
Eau: 28,201 points (4.756%) (25,380,900.0000 Meters²) 
Sols faiblement couverts: 188,452 points (31.782%) (169,606,800.0000 Meters²) 
Forêt: 26,884 points (4.534%) (24,195,600.0000 Meters²) 
Savane: 217,001 points (36.596%) (195,300,900.0000 Meters²) 
Sols nus: 62,814 points (10.593%) (56,532,600.0000 Meters²) 
Cultures et prairies: 69,604 points (11.738%) (62,643,600.0000 Meters²) 

 
 

Classification Supervisée – Préparation des données 
 
Fermez toutes les images pour ne laisser que l’image Kou_20001216_432 ouverte. 
 
La classification supervisée se déroule en deux étapes : 
 

1) La première étape consiste à sélectionner des zones de l’image dont on connaît la vraie 
occupation du sol. Ces zones sont appelées régions d’intérêt : Regions of interest (ROI). 

2) Utiliser ensuite ces zones comme références à la généralisation sur l’ensemble de l’image. 
 
 

Sélection des aires d’entrainement (Regions OfInterest) 
 
Il s’agit de sélectionner un minimum de 30 pixels spectralement représentatif de chaque 
signature spectrale identifiée précédemment. Cet échantillon, ou ‘aire d’entrainement’ est défini 
à l’écran par la numérisation d’un ou plusieurs polygones pour chaque classe spectrale. 
Sur base des polygones ainsi définis, l’extraction automatique des valeurs de pixels contenues à 
l’intérieur des polygones et le calcul de leur moyenne et écart-type produiront la signature 
spectrale de chaque classe à partir des 3 canaux de l’image Landsat. 
Pour la représentation cartographique, les différentes classes spectrales associées à un même 
taxon d’occupation du sol doivent être regroupées en une seule classe. 
 
Cliquez sur Menu Tools → Region of Interest → ROI Tool. 
 

 
 
La boite de dialogue suivante s’ouvre. 
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Dans la boîte de dialogue ROI Tool : Validez l’option Zoom. 
 
Affichez sur le même écran, la fenêtre principale et le zoom. 
 
Choisissez ensuite une zone homogène dans le zoom. 
 
A l’aide du Pixel Locator vous allez créer des régions d’intérêt sur les zones suivantes : 

Forêt (Guinguette) Sample=521 ; Line= 656 
Sols faiblement couvert Sample=585 ; Line= 500 
Savane Sample= 574 ; Line= 716 
Eau Sample= 413 ; Line= 361 
Agriculture Sample= 577 ; Line= 660 

 
La zone de la Guinguette s’affiche clairement dans le zoom : 
 

 
 
Dans ROI Tool, double-cliquez sur ‘Region1’ pour affecter un nom à cette zone test. 
 
Dans la zone de couleur en face du nom de la zone test, changez la couleur par défaut de l’outil 
de dessin par un clic droit sur la couleur affichée. 
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Commencez alors la délimitation la première zone test : Forêt. 
 
Dans la fenêtre Zoom, à l’aide de clic-gauche de la souris, créez un polygone autour d’une 
première zone de foret représentative. 
 
Pour terminer le polygone, faites 2 clics droit. 
 
On peut répéter cette opération pour un certain nombre de polygones de cette classe jusqu’à ce 
que vous jugiez avoir un nombre représentatif de pixel « foret » enregistrés comme ROI. 
 

 
 
Pour ajouter une nouvelle classe, cliquez sur New Region. 
 
Construisez petit à petit vos ROI pour vos 5 classes d’occupation du sol. 
 
Pour la classe ‘Sols faiblement couvert’ (Pixel Locator : Sample=585 ; Line=500). 
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Pour la classe ‘Savane’ (Pixel Locator : Sample=574 ; Line=716). 
 

 
 
 Pour la classe ‘Agriculture’ (Pixel Locator : Sample=577 ; Line=660). 
 

 
 
 Pour la classe ‘Eau libre’ (Pixel Locator : Sample=413 ; Line=361). 
 

 
 
Une fois toutes vos ROI réalisées, sauvez-les dans un fichier : File → Save ROIs. 
 

 
 
Cliquez sur le bouton Select All Items pour sélectionner toutes les régions d’intérêts. 
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Cliquez ensuite sur le bouton Choose afin de donner un nom de sauvegarde du fichier 
‘ROI_Kou_20001216’puis cliquez sur OK pour réaliser la sauvegarde. 
 

 
 
Dans la boîte de dialogue ROI Tool – cliquez sur Off pour arrêter les sélections. 
 

 
 
 

Statistiques et signatures spectrales sur les ROIs 
 
Cliquez sur le bouton Select All de la boite de dialogue Roi Tools pour sélectionner toutes les 
classes. 
 

 
 
Cliquez sur le bouton Stats. La boite de dialogue suivante s’ouvre. 
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Cliquez sur Select Plot puis Mean for All ROIs. 
 

 
 
Faites un clic droit sur l’image puis choisir Plot Key pour afficher la légende. 
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Une légende s’affiche à droite du graphique : 
 

 
 
Faites un clic droit sur l’image et choisissez Edit → Plot Parameters pour changer l’arrière-
plan noir en blanc. 
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Changez Background (arrière-plan) noir en blanc en faisant un clic droit sur la couleur noir 
puis sur Item 1 :20 puis White. 
 

 
 
Faites de même pour changer le Foreground (premier plan) blanc en noir. 
 
Cliquez sur Apply pour appliquer les modifications puis fermer la boite de dialogue Plot 
Parameters. 
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Séparabilité des ROIs 
 
Dans la boîte de dialogue ROI Tool cliquez sur Menu Options → Compute ROIs separability. 
 

 
 
Cliquez sur Input file: Kou_20001216_432. 
 

 
 
Puis cliquez OK. 
 
La boite de dialogue suivante apparait: 
 

 
 
Cliquez sur Select All Items pour sélectionner toutes les régions. 
 
Cliquez sur OK. 
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Ou Open Roi file pour ouvrir le fichier ROI s’il n’est pas encore ouvert. 
 
Le résultat suivant s’affiche dans un tableau. 
 

 
 
Deux méthodes de mesure de la séparabilité entre les différentes classes sont données. Les 
deux méthodes de calcul de la distance spectrale interclasses fournissent des statistiques qui 
varient entre 0 et 2 : 

- < x < 1.0 : séparabilité très faible, 0 implique une confusion totale entre deux classes ; 
- < x < 1.9 : séparabilité faible ; 
- 1.9 < x < 2.0 : bonne séparabilité, 2 séparabilité parfaite avec aucun risque de confusion. 

Une classe dont la séparabilité par rapport à une autre est faible doit être soit confondue avec 
celle-ci ou re-définie. 
 
Par exemple dans ce cas : 
 
Forêt [White] 109 points:   

Sols faiblement couverts [Red] 175 points: (2.00000000 2.00000000) 
Savane [Green] 182 points: (1.99999988 2.00000000) 
Agriculture [Blue] 38 points: (2.00000000 2.00000000) 
Eau libre [Yellow] 25 points: (2.00000000 2.00000000) 

 
Les valeurs entre parenthèse sont les valeurs de séparabilité obtenues par les deux méthodes 
mentionnées ci-dessus. 
 
Explication : La forêt a une séparabilité parfaite avec la les sols faiblement couverts, 
l’agriculture, l’eau libre (valeur égale à 2). Et une bonne séparabilité avec la savane (valeur 
comprise entre 1,9 et 2.0) 
En examinant tous les résultats, on a bonne séparabilité dans l’ensemble. On peut conclure que la 
classification a été bien faite. 
 
Fermez tous les fichiers et quittez Envi. 
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Classification supervisée 
 
Réaliser une classification supervisée d’une image satellite sous-entend que vous possédez une 
très bonne connaissance de l’occupation du sol réelle de la zone de l’image à l’époque où l’image a 
été prise. Cette connaissance peut venir de plusieurs sources : une enquête de terrain ou une 
photo-interprétation de l’image à condition d’être suffisamment sur de votre jugement. Comme il 
n’y a pas eu d’enquête de terrain, vous aurez recours à la deuxième méthode. 
 
A partir de votre connaissance de la région étudiée et de l’examen de la composition colorée de la 
zone à classifier définissez la légende de la carte. 
Identifiez également combien de signatures spectrales différentes correspondent à chaque 
taxon de la légende. En effet, une occupation du sol telle que ‘culture’ peut présenter différentes 
signatures spectrales au moment de l’enregistrement de l’image, selon l’espèce cultivée et son 
stade végétatif. Il s’agit donc de définir autant de signatures spectrales qu’il existe de 
situations spectralement bien différentes pour chaque occupation du sol. L’algorithme de 
classification pourra ainsi traiter chaque signature spectrale de manière indépendante. 
 
L’objectif de la classification supervisée ou dirigée consiste à rattacher tous les pixels de l’image 
à une classe d’occupation du sol identifiée à priori. Ainsi, suppose-t-on que les statistiques 
calculées sur des échantillons sélectionnés à priori sont représentatives des classes et 
suffisantes pour effectuer la discrimination des pixels. 
 
Dans ROI Tool -> Restore ROI 
 
On testera les méthodes suivantes : 

 Minimum Distance ; 
 Mahalanobis Distance; 
 Parallelepiped; 
 Maximum likelihood (maximum de vraisemblance). 

 
 

Minimum Distance 
 
Démarrez Envi et chargez le fichier Kou_20001216_432. 
Chargez également le fichier de région d’intérêt dénommé Roi_Kou_20001216.roi situé dans 
le répertoire C:\Formation_Envi\Output à partir de Tools → Région of Interest de la boite de 
dialogue de ROI Tool, en cliquant sur File → Restore ROIs. 
 
Dans le menu principal ENVI cliquez Classification → Supervised → Minimum Distance. 
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Dans la boite de dialogue suivante sélectionnez le fichier et cliquer sur OK. 
 

 
 
Une autre boite de dialogue s’ouvre. 
 

 
 
Cliquez sur Select All Items pour sélectionner toutes les régions d’intérêt. 
 
Changez Output Rule Images en No et donnez Class_Mindist_Kou_20001216comme nom de 
fichier issu de la classification. 
 
Puis cliquez sur OK. 
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Affichez ensuite les deux images, l’image classée et la composition colorée. 
 
Et utilisez l’outil Tools → Link → Link Displays pour vérifier les résultats de la classification. 
 

 
 
Fermez tous les fichiers et quittez ENVI. 
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Classification par Maximum Likelihood (Maximum de ressemblance) 
 
Le principe de la classification dirigée par la procédure de ‘maximum de vraisemblance’, lors de 
laquelle la signature spectrale de chaque pixel, dans chacun des trois canaux (4, 3 et 2) est 
comparée à celle des zones d'apprentissage ou régions d’intérêt. Les pixels sont alors affectés 
dans la classe dont ils sont le plus proches. 
 
Démarrez à nouveau ENVI. 
Ouvrez et chargez le fichier Kou_20001216_432 à partir de C:\Formation_Envi\Input. 
Chargez l’image en composition colorée RGB. 
 
Dans le menu Tools de Display cliquez sur Regions of Interest → ROI Tool. 
 

 
 
La boite de dialogue ROI Tool apparait. 
 
Importez le fichier des régions d’intérêt dénommé Roi_Kou_20001216.roi précédemment 
utilisé pour pouvoir réaliser cette classification de Maximum de vraisemblance. 
 

 
 
L’écran suivant apparait : 
 

 
 
Cliquez sur OK pour charger les régions d’intérêt. 
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Supprimez la première ligne qui est vide en la sélectionnant puis en cliquant sur le bouton 
Delete. 
 
Cliquez sur Classification → Supervised → Maximum Likelihood dans la barre de menu 
principale d’ENVI. 
 

 
 
Sélectionnez l’image à classifier Kou_20001216_432 puis cliquez OK. 
 
Le fichier de Roi étant déjà ouvert, dans la fenêtre Maximum Likelihood Parameters cliquez 
sur le bouton Select All Items pour sélectionner toutes les classes. 
Choisissez Single Value et prenez 0,5 pour le seuil de probabilité (Probability Threshold). 
Enregistrez votre classification comme fichier ‘Maxclas_Kou_20001216’ dans votre farde. 
 Désactivez l’Output Rule Images. 
 

 
 
Cliquez OK. 
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La classification se réalise. L’algorithme de classification selon le maximum de vraisemblance est 
appliqué à tous les pixels de l’image sur base des paramètres statistiques décrivant chaque 
signature spectrale obtenue. La comparaison entre les valeurs de chaque pixel et les signatures 
spectrales des différentes classes déterminera la probabilité d’appartenance du pixel à chacune 
des classes. La classe présentant la probabilité maximum sera attribuée au pixel considéré. 
 
Le résultat apparait dans la fenêtre Available Bands List : 
 

 
 
Visualisez votre résultat dans un nouveau Display. 
 
Comparez ce résultat avec l’image de base par lien dynamique synchronisé des displays. 
Cette comparaison vous permet d’identifier les défauts éventuels de votre classification et donc 
de l’améliorer. 
 
Testez cette méthode également pour des valeurs de probabilité de 0, 0.75, 1. 
 
Examinez et commentez les résultats correspondant aux différentes valeurs de probabilité. 
Pour une valeur de probabilité égale à 0, tous les pixels de l’image sont classés. Alors que pour 
une valeur de probabilité égale à 1 aucun pixel n’est classé. 
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Réalisation d’une carte d’occupation du sol 
 
Une fois votre image classifiée, exportez le résultat : 
 
Cliquez File → Save Image As… → Image File dans le viewer contenant votre classification. 
Ignorez le message d’erreur qui apparait, s’il apparait 
Choisissez TIFF/GeoTIFF comme Output File Type pour que cette image exportée soit 
compatible avec ArcGIS que vous utiliserez pour la mise en page de votre carte. 
Enregistrez cette image dans votre farde Résultat et appelé la VotreNOM_Carte.tif 
 
L’image a été exportée. 
 
Pour la mise en page de votre carte, utilisez ArcMap (ArcGis). Insérez votre carte dans un 
nouveau projet ArcMap et passez en mode layout view. Respectez les consignes d’édition 
cartographique données dans le manuel de Formation SIG.  
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Chapitre 5 
Analyse temporelle 
 

 
 

Normalized Difference Vegetation Index (NDVI) 
 
Le NDVI est un indice de végétation qui se définit comme la différence normalisée des mesures 
de réflectance spectrale acquises dans les zones de longueurs d’onde ‘Proche Infra-Rouge’ (PIR) 
et ‘Rouge’ : 
 
NDVI = (PIR - Rouge) / (PIR + Rouge) 
 
Sa valeur varie théoriquement varie entre -1 et 1. En pratique, une surface d’eau libre (océan, 
lac,…) prendra des valeurs de NDVI proches de 0, un sol nu prendra des valeurs de 0.1 à 0.2, 
alors qu’une végétation dense aura des valeurs de 0.5 à 0.8. 
 
Les plantes vertes absorbent une grande partie des radiations solaires dans une zone de 
longueurs d’onde appelée PAR (Photosynthetically Active Radiation), dont fait partie la zone du 
Rouge. Par contre, le PIR est fortement diffusé (non absorbé : transmis et réfléchi) par la 
plante. Par conséquent, une plante verte vive apparait sombre dans le PAR (dont le rouge) car ces 
longueurs d’ondes sont absorbées par la plante (petite valeur de réflectance), et brillante dans le 
PIR car ces longueurs d’ondes sont réfléchies en partie (grande valeur de réflectance). 
Le NDVI est directement lié à l’activité photosynthétique des plantes et donc à la capacité 
d’absorbation énergétique de la canopée du couvert végétal. Il agit comme indicateur de la 
biomasse chlorophyllienne des plantes. En termes de réflectance dans le PIR et le Rouge. 
 
Une végétation en bonne santé absorbe la plupart de la lumière visible qu’il intercepte et 
réfléchit une partie importante de la lumière PIR. Une végétation en mauvaise santé ou clair 
semée réfléchi plus de lumière visible et moins de PIR. 
 
 

Création d’un indice de végétation radiométrique NDVI 
 
Démarrez une nouvelle session d’Envi. 
Ouvrez l’image Landsat du bassin du Kou ‘Kou_20070110’. Elle date du 10 janvier 2007. 
 

 
 
La boite de dialogue suivante s’ouvre : 
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Puis charger l’image en RGB (RGB). 
On rappelle que la bande 4 = proche IR, la bande 3 = rouge et la bande 2 = vert. 
 

 
 
Dans le menu principal de la barre d’outils ENVI cliquez sur le menu Transform → NDVI. 
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Sélectionnez ensuite l’image Kou_20070110 puis validez par OK. 
 

 
 
Lorsque les longueurs d’ondes sont connues, ENVI calculera les bandes qui sont nécessaires pour 
le calcul de NDVI. Si une image sans les longueurs d’ondes mentionnées sur le header a été 
choisie, alors vous devez identifier les bandes qui correspondent au rouge et à l’infrarouge pour 
le calcul du NDVI (c’est le cas dans cet exercice). 
 
Choisissez les bandes correspondantes et donnez le nom NDVI_Kou_20070110 au nom de 
l’image NDVI créée (red = bande 3, ici la bande 2, near IR = 4 ici la bande 1). 
 
Choisissez Floating Point comme Output Data Type, puis cliquez OK. 
 

 
 
L’image NDVI est ajoutée à la liste d’images dans la boîte Available Bands list. 
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Affichez ensuite l’image en mode Gray scale sur une nouvelle fenêtre Display 2. 
 
L’écran doit comporter les deux fenêtres : la composition colorée et l’image NDVI.  
 

 
 
Afin de lier spatialement ces deux images, dans le menu Tools de l’une de deux fenêtres 
Display, cliquez sur l’option Link puis Link Displays. 
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La boite suivante s’ouvre : 
 

 
 
Maintenez les Yes. Cette opération synchronise les fenêtres de visualisation sélectionnées. 
Maintenez Dynamic Overlay sur On. Cette opération permet une superposition dynamique des 
images des différentes fenêtres de visualisation synchronisées. 
Indiquez une Transparency (opacité en réalité) de 0 %. Cette opération permet de rendre la 
couche supérieure d’une fenêtre de visualisation transparente en cliquant dessus. 
Ne modifiez pas les Link Size / Position. 
Cliquez OK. 
 
Les deux fenêtres sont spatialement liées : la même zone de l’image est affichée sur les deux 
fenêtres. En cliquant sur l’une des deux images à l’aide du bouton gauche de la souris, on affiche 
l’autre image. 
 
Pour les différentes unités de paysage : eau, différents types de forêts, sols nus, cultures,… 
déterminez l’ordre de grandeur de l’indice NDVI. 
 
 Afin de faciliter la recherche des différentes unités, ouvrez le Pixel Locator du menu Tools. 
 

 
 
Insérer éventuellement un par un les valeurs suivantes dans le Pixel Locator : 

- Eau :  Sample= 414 ; Line= 366 NDVI= -0.180328 
- Forêt :  Sample= 521 ; Line= 656 NDVI= 0.325843 
- Sols nus : Sample= 609 ; Line= 420 NDVI= -0.097222 
- Cultures : Sample= 473 ; Line= 355 NDVI= 0.264151 
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 Cliquez sur Apply afin que le curseur se déplace. 
 
Utilisez ensuite pour trouver les différentes valeurs NDVI le Cursor Location/Value du même 
menu Tools de la fenêtre Display. 
 

 
 
La valeur de NDVI se trouve sur la ligne : Disp #2 Data : -0.180328. 
 

 
 
Une autre possibilité pour créer un indice NDVI, ou toute autre combinaison de bandes, est 
donnée par l’outil Band Math : 
 
Cliquez sur Basic Tools → Band Math, pour y accéder. 
Ensuite il vous suffira de taper une expression du type b4 – b3/(b4 – b3) dans la fenêtre 
Enter an expression, de cliquer Add to List, de la sélectionner, et de définir par sélection les 
bandes. 
 
Créez également une image NDVI pour l’image Kou_19860116 se trouvant dans le répertoire 
C:\Formation_ENVI\Input que vous nommerez NDVI_Kou_19860116. 
Enregistrez-le dans le répertoire C:\Formation_ENVI\output. 
 
Chargez les deux images NDVI créées : NDVI_Kou_19860116 et NDVI_Kou_20070110 
successivement dans les vues 1 et 2. 
 
Cliquez sur Tools → Link → Link Displays dans la barre de menu d’une des fenêtres de 
visualisation que vous voulez synchroniser. 
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Testez rapidement la synchronisation de vos fenêtres à partir d’une ‘Scroll window’ et la 
superposition dynamique à partir d’une ‘Image window’. 
 
 

Symbologie 
 
Cliquez sur Tools → Color Mapping → ENVI Color Tables dans la barre de menu d’une des 
fenêtres de visualisation dont vous voulez changer la symbologie. 
 

 
 
Explorez les différents types de symbologie et choisissez une symbologie qui vous paraît 
idéale pour comparer les 2 images, par exemple, la symbologie BLUE/GREEN/RED/YELLOW. 
 

 
 
Répétez ces opérations pour l’autre fenêtre de visualisation. 
 
Comparez visuellement ces 2 images. Aidez-vous notamment du ‘Cursor Location / Value’. 
 
Avec la symbologie ‘BLUE/GREEN/RED/YELLOW’, quelles couleurs sont associées à une faible et 
importante valeur de NDVI ? Que remarquez-vous ? Réfléchissez en termes d’évolution spatio-
temporelle du NDVI. Cette évolution est-elle la même partout sur l’image ? 
 
 

Analyse de détection du changement (Change detection analysis) 
 
L’analyse de détection du changement comprend de nombreuses méthodes dont le but est 
d’identifier, de décrire et de quantifier, les différences entre images d’une même scène (même 
endroit) prises à différents moments (janvier 1986 et janvier 2007) ou dans des conditions 
différentes. 
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Avez-vous une idée des situations dans lesquelles ce genre d’analyse peut être utile ? 
 
Vous allez maintenant utiliser l’un des outils les plus simples d’ENVI pour l’analyse de détection 
du changement : Compute Difference Map. Cet outil permet d’analyser le changement entre une 
paire d’images représentant un stade initial et un stade final (avant et après le changement). 
L’output résultant de cette opération est calculé en soustrayant l’image initiale de l’image finale 
(finale – initiale) et consiste en une image classifiée dont les classes sont définies par des seuils 
de changement. 
Cette image de changement informe sur la nature du changement apparu : pas de changement, 
changement positif ou négatif, changement important ou faible en termes de surface ou 
d’intensité. 
 
Pour analyser le changement en termes de couverture végétale sur le Bassin du Kou entre janvier 
1987 et janvier 2007, réalisez les opérations suivantes : 
 
Allez dans le menu principal d’ENVI Basic Tools → Change Detection → Compute Difference 
Map. 
 

 
 
Dans la fenêtre Select the ‘Initial State’ Image, sélectionnez l’image ante changement 
(image avant changement),dans ce cas-ci, l’image NDVI_Kou_19860116. 
 

 
 
 Cliquez OK. 
Dans la fenêtre Select the ‘Final State’ Image sélectionnez l’image post changement, dans ce 
cas-ci l’image NDVI_Kou_20070110. 
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Cliquez OK. 
 
Dans la fenêtre Compute Difference Map Input Parameters, choisissez 5 classes. 
 

 
 
Cliquez sur le bouton Define Class Thresholds pour définir les seuils. 
 
La boite suivante s’affiche : 
 

 
 
Dans votre cas laissez les seuils par défaut et cliquez sur OK pour aller de nouveau vers la 
boîte Compute Difference Map Input Parameters. 
 
Plusieurs méthodes de calcul de changement s’offrent à vous. Vous allez essayer la méthode 
‘Simple Difference’ avec et sans preprocessing de normalisation : 
 
- La méthode Simple Difference réalise une simple différence entre les valeurs de Digital 

Number (DN) des deux images NDVI. 
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En comparant vos deux images (NDVI_Kou_19860116 et NDVI_Kou_20070110) à l’aide du 
‘cursor/location value tool’, faites-vous une idée sur la gamme de valeurs qui ressortira de 
cette analyse. 

- Le preprocessing Normalize Data range (0 – 1) réalise un prétraitement consistant en : 
(DN – min) / (max – min) qui réduit la gamme des valeurs de chaque image entre 0 et 1. 
En utilisant cette méthode, quelle gamme de valeurs ressortira de l’analyse de changement 
avec les 2 images NDVI ? 
 

Cochez Simple Difference. 
Choisissez d’enregistrer vos images résultats comme fichier dans le répertoire 
C:\Formation_ENVI\output avec comme nom : SD_5class_an86_an07. 
 
Cliquez sur OK. 
 
Le fichier résultat apparait dans la boite de dialogue Available Bands List. 
 

 
 
Ensuite, chargez l’image de changement classifiée dans une nouvelle fenêtre de visualisations 
que vous synchronisez avec les images de base (NDVI) et comparez. 
 
L’image montre le changement qui a eu lieu entre les deux images NDVI_Kou_19860116 et 
NDVI_Kou_20070110. Pour voir la légende, allez à Tools → Color Mapping → Class Color Mapping 
de l’image de SD_5class_an86_an07. 
 
La couleur RGB (127, 127, 127) représente la zone sans changement. La couleur RGB (192, 63, 63) 
représente des zones de changements positifs. La couleur RGB (63, 63, 192) représente des zone 
de changement négatif.  
 
Cette image montre un véritable changement de NDVI entre les deux années. Commentez les 
résultats obtenus. 
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Chapitre 6 
Classification par arbre de décision 
 

 
 

Démarrer la session 
 
L’image utilisée dans cet exercice est une portion d’une image Landsat 7ETM du bassin du Kou. 
 
Démarrez le logiciel par l’une des manières que vous connaissez. 
 
A partir de la barre de Menu de ENVI, sélectionner File → Open Image File.  
Naviguez jusqu’au répertoire C:\Formation_ENVI\Input\sélectionnez le fichier 
Kou_20070518_432 de la liste et cliquez ouvrir (open). 
 
La liste des bandes disponibles apparait à l’écran. 
 
Chargez les bandes 432 comme ci-dessous. 
Cliquez sur No Display et sélectionnez New Display.  
Cliquez sur Load RGB. 
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Examinez l’image. Visualisez les données de l’image à partir du pixel locator, avant de 
construire l’arbre. Cela peut être utile. 
 
 

Introduire les règles de l’arbre décisionnel 
 
A partir de la barre du menu principal d’Envi, sélectionnez Classification → DecisionTree → 
Build New DecisionTree. 
 

 
 
La boite de dialogue de l’arbre de décision d’Envi apparait. Par défaut, l’outil de l’arbre de 
décision commence avec un nœud de décision vide  qui divisera les pixels de l’ensemble des 
données en deux groupes, utilisant n’importe quelle expression de décision binaire introduite dans 
ce nœud vide.  
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Pour définir la décision, cliquez sur le nœud de décision intitulé Node 1. 
 
La boite de dialogue de modification de décision apparait.  
 

 
 
Au niveau du champ Name, tapez NDVI >=0.4231. C’est le texte qui apparaitra au niveau du 
nœud de décision dans la vue graphique de l’arbre de décision. 
 
Dans le champ Expression, tapez :{ndvi} ge 0.4231 
 
L’expression entrée dans le champ dit à Envi de diviser les pixels en ceux qui ont des valeurs de 
NDVI inférieures et supérieures à 0.4231.  
NDVI est l’indice fréquent de végétation verte abondante calculé à partir des bandes du rouge 
et de l’infra-rouge d’une image multispectrale. L’arbre de décision calculera l’indice de végétation 
NDVI pour chaque pixel, et  trouvera les pixels qui possèdent des valeurs supérieures ou égales à 
0,4231.  
 
Puis cliquez sur OK. 
 
La boite de dialogue Variable/Files Pairings apparait.  
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Dans la boite de dialogue Variables/Files Pairing, cliquez une fois sur la variable {ndvi}. 
 
La boite de dialogue du fichier sélectionné à associer avec la variable apparait. 
 

 
 
Sélectionnez le fichier dénommé Kou_20070518_432et cliquez OK. 
 
Cette étape dit à l’arbre de décision qu’en évaluant l’expression de décision, les valeurs de NDVI 
devraient être calculée à partir de l’image Kou_20070518_432. 
 
Lorsque les longueurs d’ondes sont connues, ENVI calculera les bandes qui sont nécessaires pour 
le calcul de NDVI. Si une image sans les longueurs d’ondes mentionnées sur le header a été 
choisie, alors vous devez identifier les bandes qui correspondent au rouge et à l’infrarouge pour 
le calcul du NDVI. C’est le cas dans cet exercice. 

 
 
Entrez 1 dans Near IR Band et 2 dans Red Band, puis cliquez OK. 
 
L’écran suivant apparait : 
 

 
 
Cliquez le menu Options puis sur Execute pour exécuter la classification. 
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 Contentez-vous de temporairement stocké le résultat dans Memory, cliquez OK. 
 

 
 
 

Entrer des règles additionnelles 
 
C’est maintenant un simple classificateur d’arbre de décision. Les pixels avec NDVI supérieur ou 
égal à 0.4231 seront inclus dans classe 1 (Class 1) (la classe blanche), et les pixels avec NDVI 
inférieur à 0.4231 seront inclus dans la classe 0 (Class 0) (la classe noire). Vous pouvez entrer 
des règles de décisions additionnelles pour développer une classification plus compliquée.  
 
Faites un clic droit sur le nœud Class 1 et sélectionnez Add Children pour subdiviser les 
pixels avec NDVI élevé en sous catégories. 
 

 
 
Deux nouvelles classes sont automatiquement crées en dessous de la classe 1.  
 

 
 
Le nœud qui était préalablement intitulé classe 1 est maintenant vide. 
 
Cliquez une fois sur ce nœud. La boite de dialogue de modification de propriété apparait.  
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Dans le champ Name, tapez Ndvi>=0.4892 
 
Dans le champ Expression, tapez: {ndvi} ge0.4892et cliquez OK. 
 

 
 
La décision va diviser les pixels de NDVI élevés en deux autres classes de NDVI. 
 
A partir de la barre de menu de la boite de dialogue de ENVI Decision Tree sélectionnez 
Options → Execute, 
Ou faites un clic droit sur la zone arrière-plan de couleur blanche de la boite de dialogue de 
ENVI Decision puis choisissez Execute. 
 

 
 
La boite de dialogue de Decision Tree Execution Parameters apparait. 
 

 
 
Choisissez le répertoire dans lequel il faut enregistrer le fichier :  
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C:\Formation_ENVI\Output\Kou_20070518_432_arb. 
 
Cliquez sur OK. 
 
Le résultat s’affiche automatiquement dans la boîte Available Bands List. 
 
 

Visualiser les résultats de l’arbre de décision 
 
La couleur d’un pixel donné dans le résultat est celle de la classe à laquelle il appartient après 
classification à partir de l’arbre de décision. Ainsi, par  exemple, les pixels noirs sont ceux qui 
ont des valeurs de NDVI inférieure à 0.4231dans l’arbre de décision. 
 
Examinez l’arbre de décision d’Envi une fois encore. Notez que la vue par défaut ne comporte 
pas toutes les informations qui devraient être affichées. 
 
Faites un clic droit sur l’arrière-plan blanc de la boite de dialogue de ENVI Decision Tree et 
sélectionnez Zoom In. 
L’étiquette de chaque nœud affiche le nombre de pixels et le pourcentage de l’image entier qui 
progresse à chaque nœud de l’arbre. On peut redimensionner la fenêtre de l’arbre de décision 
pour visualiser la fenêtre complète. 
 
Placez le curseur de la souris sur n’importe quel nœud de l’arbre de décision, et notez 
l’information dans la barre de statut en bas de la boite de dialogue de ENVI Decision Tree . 
C’est un autre moyen utile pour avoir rapidement de l’information sur un nœud dans l’arbre, 
spécifiquement si la vue de l’arbre n’est pas zoomée pour montrer les détails du nœud.  
 

 
 
L’arbre de décision dispose des fonctionnalités permettant des mises après avoir élaboré des 
classifications. On peut notamment procéder : 

- au changement de couleur de classes et de noms ; 
- à l’émondage (Prune) de l’arbre (enlever temporairement les descendants) afin de les 

réinstaller sans redéfinir la règle de décision ou les propriétés de nœud ; 
- supprimer (Delete) définitivement les descendants de l’arbre. 
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C’est possible de sauvegarder les arbres de décision, incluant tous les appariements entre les 
variables et les fichiers. Sauvegardez un arbre de décision vous permet de le restaurer dans une 
session prochaine de ENVI.  
 
Du menu de la barre de l’arbre de décision, sélectionnez File → Save Tree. La boite de 
dialogue de sauvegarde de l’arbre de décision apparait.  
 
Tapez un nom de fichier de sortie pour l’arbre, et cliquez OK.  
 
Vous pouvez quitter votre session d’ENVI en sélectionnant File → Exit à partir du menu 
principal d’ENVI. 
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Chapitre 7 
 Evaluation et appréciation de la classification 
finale (analyse de la matrice de confusion) 
 

 
 

 Le  contrôle  de  la  classification  se  fait  sur  la base  d’un échantillon de pixels vérifiés sur le 
terrain.    L’échantillonnage  se  fait  sur  l’ensemble  de  l’image  (et pas uniquement dans les 
sites d’entraînement): 
–  Avec  une  distribution  spatiale  aléatoire  et  une  distribution  par classe aléatoire, 
proportionnelle ou égale. 
–  Avec une distribution spatiale systématique (quadrillage). 
–  Avec une distribution spatiale fonction des données à disposition (fonction du trajet de la 
mission de terrain) 
•   Le nombre de pixels de l’échantillon est compris entre 30 et 60 selon la couverture relative de 
chaque classe. 
 
l'approche suivante est adoptée: 
 
 Digitaliser     les     points correspondants aux sites de   référence   dans   un fichier ROIs. 
•   Lancer  :  Classification  >Confusion Matrix > Using Ground Truth ROIs. 
•   Sélectionner l’image issue de la classiffication. 
•   Confirmer en cliquant OK. 
•   Vérifier les combinaisons et  confirmer  en  cliquant OK. 
•   Confirmer en cliquant OK. 
 
 

Démarrer la session 
 
Démarrez Envi et chargez le fichier Kou_20001216_432 situé dans le répertoire 
C:\Formation_ENVI\input. 
Nous allons à présent créer des zones relevées sur le terrain à l'aide des coordonnées GPS qui 
serviront à construire les régions pour les occupations suivantes: 

Forêt  (334050 E; 1237140 N) 
Sols faiblement couverts (344220 E; 1252260 N) 
Savanes  (346380 E; 1237590 N) 
Agriculture  (332760 E; 1256280 N) 
Créez de petites zone de 30 à 60 pixels autours de ces points GPS. 
Enregistrez le fichier de ces régions nouvellement créées sous le nom Contrôle régions 
occupation 20001216_432.roi. 

Charger à présent votre fichier issu de votre classification  dénommé Maxclax_Kou_20001216 
situé dans le répertoire C:\Formation_ENVI\Output. 
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Cliquez Classification → Post Classification→Confusion Matrix → Using Ground Truth 
ROIs  
 
 

 
La boite de dialogue suivante s'ouvre: 
 
 

 
Choisissez votre fichier image dénommé Maxclax_Kou_20001216 résultat de votre 
classification 

 
Cliquer sur Ok. 
Dans la boite de dialogue qui s'ouvre faites les correspondances qui permettent de faire la 
classification: 
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Cliquez sur Add Combination puis sur Ok pour valider la correspondance. 
Laissez les choix dans la boite suivante qui s'affiche par défaut puis cliquez sur Ok. 

 
La boite de  dialogue suivante affiche les résultats de la comparaison de la classification. Vous 
pouvez élargir les bords de la boite pour afficher tous les résultats. 
 

 
Procédez donc à l'analyse des résultats pour apprécier votre classification. 
Vous avez les résultats en pourcentage et en pixels. 
 
Les clés de l'interprétation des résultats  
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 Différents  indicateurs  de  précision  sont  proposés :  Overall Accuracy (précision  globale), 
coefficient Kappa, Commission (erreurs d’excédents et de déficits), Omission (L’erreur de 
déficit),  User Accuracy  (précision pour l’utilisateur) et (Producer Accuracy) précision pour le 
réalisateur.  
Overall Accuracy qui signifie la précision totale ou globale qui est le rapport entre le nombre de 
pixels bien classés sur le nombre total de pixels. Les diagonales du tableau de matrice nous 
donnent les pixels bien classés 
  Kappa Coefficient qui les le coefficient Kappa  est une autre manière d'évaluer la précision en 
faisant intervenir son calcul tous les pixels de contrôle relevés sur le terrain et données des 
diagonales. Ce coefficient est compris entre 0 et 1. 
Commission (L’erreur d’excédents) correspond à l’affectation de pixels d’une classe calculée 
(groupe de classification) à d’autres classes des données de référence (terrain).  Elle est 
calculée selon les lignes.  
Omission (L’erreur de déficit) correspond à l’affectation des pixels d’une classe de référence 
(données terrain) à d’autres classes calculées (groupes de classification). Elle est calculée selon 
les colonnes.  
Producer Accuracy (précision pour le réalisateur ) correspond au pourcentage de pixels issus des 
classes de référence bien classés dans les groupes d’affectation. Elle est calculée selon les 
colonnes.  
 User Accuracy  (La précision pour l’utilisateur)  représente le pourcentage de pixels bien 
classés (par rapport au nombre total de pixels de la classe). Elle est calculée selon les lignes.  
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